25 feb. 2013

Lanzado CD Tray 1.0.0

CD Tray, mi reproductor de CD's de música para la bandeja del sistema para GNU/Linux a llegado a la madurez.
Los cambios en esta versión 1.0.0 (correspondiente a la r10 de desarrollo) son:

  • Ahora se puede seleccionar la salida de audio entre ALSA, Pulse y OSS
  • Al arrancar busca donde se encuentra la librería libc6.so.6, evitando así tener que hacer parches para algunas versiones de Debian, Ubuntu, Linux Mint, etc
  • Se han corregido un par de cosas de poca importancia.

Los enlaces a las descargas las podéis encontrar en la pagina del programa

12 comentarios:

Anónimo dijo...

Son Link , al ejecutar el programa se produce el siguiente error

[URL=http://imageshack.us/photo/my-images/820/capturadepantallacdtray.png/][IMG]http://img820.imageshack.us/img820/169/capturadepantallacdtray.png[/IMG][/URL]

Uso Xubuntu 12.04

Decime como instalar los paquetes necesarios, ya que en synaptic me aparece como instalado python 2.7.3 0ubuntu2 , por si me falta alguno

Gracias . Gustavo

Anónimo dijo...

Va de nuevo el link:

http://img820.imageshack.us/img820/169/capturadepantallacdtray.png

gracias . Gustavo

Alfonso Saavedra Chichon dijo...

Ejecútalo desde una terminal que dirá mejor donde esta el fallo, ademas revisa que tienes instalado el resto de paquetes que indico en la pagina del proyecto.

Anónimo dijo...

por consola :

http://img42.imageshack.us/img42/51/capturadepantallaerrorc.png

La busqueda de los paquetes en synaptic me muestra que estan instalados

Anónimo dijo...

http://img18.imageshack.us/img18/51/capturadepantallaerrorc.png

Disclpa el tamaño . Gracias . Gustavo

Alfonso Saavedra Chichon dijo...

Por favor, ejecuta este en la terminal y sube la salida:
find | grep 'libc6.so.6'
Aparte ¿usas la versión de 32 (i386) o de 64 bits (amd64) de Ubuntu?

Anónimo dijo...

http://img145.imageshack.us/img145/169/capturadepantallacdtray.png

Uso la version de 64 bits (AMD 64) de Xubuntu

Alfonso Saavedra Chichon dijo...

Ups, se me paso poner una cosa XD
Es find /lib | grep 'libc6.so.6'

Anónimo dijo...

Cuando tenga acceso a la maquina, en un par de dias, te cuento. Desde ya muchas gracias. Gustavo

Anónimo dijo...

Son link, acá te mando la captura

http://img706.imageshack.us/img706/169/capturadepantallacdtray.png

Te cuento que en otra PC con Xubuntu 12.10 funciona perfecto.

Gracias. Gustavo

Alfonso Saavedra Chichon dijo...

Ok, encontré el "error"
Al buscar la ruta puede que si uno usa una versión para 64 bits y tiene instalado la versión de libc para 32 bits encontrara 2 archivos y tomara el primero que encuentre, en tu caso la ruta al de 32 bits y por eso da ese error.
De momento esto solo veo que pasa en Debian, Ubuntu, Mint y otras derivadas, ya que en Archlinux y derivadas la ruta es siempre la misma instalando la versión de libc en la versión de 64 bits (que es la que uso) en /usr/lib.
De momento parece que solo pasa en estas distros.

Antes de actualizar el repositorio, por favor sustituye el archivo cdtray.patch por este y dime si ya te funciona:
https://gist.github.com/son-link/5085112
Como ya se las 3 posibles rutas he quitado el bucle for y ahora busca si esta en /usr/lib, luego en /lib/x86_64-linux-gnu y por ultimo en /lib/i386-linux-gnu

Anónimo dijo...

Funciona!! Corriendo sin problemas!.Te haré llegar mi opinion de usuario ! Muchas gracias!

Gustavo

Publicar un comentario en la entrada

Twitter Delicious Facebook Digg Stumbleupon Favorites More

 
Powered by Blogger